import Foundation
let pattern = #""[A-Za-z]+ ([A-Za-z ]+)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
>genus [1] "Bellatorias obiri" "Caretta caretta" [3] "Cyclodomorphus praealtus" "Dermochelys coriacea" [5] "Egernia stokesii badia" "Elseya lavarackorum" [7] "Elusor macrurus" "Eulamprus leuraensis" [9] "Eulamprus tympanum marnieae" "Lepidochelys olivacea" [11] "Lerista allanae" "Liopholis guthega" [13] "Liopholis slateri slateri" "Lucasium occultum" [15] "Tiliqua adelaidensis" "Tympanocryptis pinguicolla"
>genusnew [1] "obiri" "caretta" "praealtus" "coriacea" [5] "badia" "lavarackorum" "macrurus" "leuraensis" [9] "marnieae" "olivacea" "allanae" "guthega" [13] "slateri" "occultum" "adelaidensis" "pinguicolla" – Kiwi Power 45 secs ago
> species [1] "obiri" "caretta" "praealtus" "coriacea" [5] "badia" "lavarackorum" "macrurus" "leuraensis" [9] "marnieae" "olivacea" "allanae" "guthega" [13] "slateri" "occultum" "adelaidensis" "pinguicolla"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)