re = /"[A-Za-z]+ ([A-Za-z ]+)"/
str = '>genus [1] "Bellatorias obiri" "Caretta caretta" [3] "Cyclodomorphus praealtus" "Dermochelys coriacea" [5] "Egernia stokesii badia" "Elseya lavarackorum" [7] "Elusor macrurus" "Eulamprus leuraensis" [9] "Eulamprus tympanum marnieae" "Lepidochelys olivacea" [11] "Lerista allanae" "Liopholis guthega" [13] "Liopholis slateri slateri" "Lucasium occultum" [15] "Tiliqua adelaidensis" "Tympanocryptis pinguicolla"
>genusnew [1] "obiri" "caretta" "praealtus" "coriacea" [5] "badia" "lavarackorum" "macrurus" "leuraensis" [9] "marnieae" "olivacea" "allanae" "guthega" [13] "slateri" "occultum" "adelaidensis" "pinguicolla" – Kiwi Power 45 secs ago
> species [1] "obiri" "caretta" "praealtus" "coriacea" [5] "badia" "lavarackorum" "macrurus" "leuraensis" [9] "marnieae" "olivacea" "allanae" "guthega" [13] "slateri" "occultum" "adelaidensis" "pinguicolla" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end