use strict;
my $str = '>genus [1] "Bellatorias obiri" "Caretta caretta" [3] "Cyclodomorphus praealtus" "Dermochelys coriacea" [5] "Egernia stokesii badia" "Elseya lavarackorum" [7] "Elusor macrurus" "Eulamprus leuraensis" [9] "Eulamprus tympanum marnieae" "Lepidochelys olivacea" [11] "Lerista allanae" "Liopholis guthega" [13] "Liopholis slateri slateri" "Lucasium occultum" [15] "Tiliqua adelaidensis" "Tympanocryptis pinguicolla"
>genusnew [1] "obiri" "caretta" "praealtus" "coriacea" [5] "badia" "lavarackorum" "macrurus" "leuraensis" [9] "marnieae" "olivacea" "allanae" "guthega" [13] "slateri" "occultum" "adelaidensis" "pinguicolla" – Kiwi Power 45 secs ago
> species [1] "obiri" "caretta" "praealtus" "coriacea" [5] "badia" "lavarackorum" "macrurus" "leuraensis" [9] "marnieae" "olivacea" "allanae" "guthega" [13] "slateri" "occultum" "adelaidensis" "pinguicolla" ';
my $regex = qr/"[A-Za-z]+ ([A-Za-z ]+)"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}