const regex = /"[A-Za-z]+ ([A-Za-z ]+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[A-Za-z]+ ([A-Za-z ]+)"', 'g')
const str = `>genus [1] "Bellatorias obiri" "Caretta caretta" [3] "Cyclodomorphus praealtus" "Dermochelys coriacea" [5] "Egernia stokesii badia" "Elseya lavarackorum" [7] "Elusor macrurus" "Eulamprus leuraensis" [9] "Eulamprus tympanum marnieae" "Lepidochelys olivacea" [11] "Lerista allanae" "Liopholis guthega" [13] "Liopholis slateri slateri" "Lucasium occultum" [15] "Tiliqua adelaidensis" "Tympanocryptis pinguicolla"
>genusnew [1] "obiri" "caretta" "praealtus" "coriacea" [5] "badia" "lavarackorum" "macrurus" "leuraensis" [9] "marnieae" "olivacea" "allanae" "guthega" [13] "slateri" "occultum" "adelaidensis" "pinguicolla" – Kiwi Power 45 secs ago
> species [1] "obiri" "caretta" "praealtus" "coriacea" [5] "badia" "lavarackorum" "macrurus" "leuraensis" [9] "marnieae" "olivacea" "allanae" "guthega" [13] "slateri" "occultum" "adelaidensis" "pinguicolla" `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}