re = /Laser Projection Subunits for the (?<Extracted_value>.*?)<\/td>/m
str = '<td valign="top">23.01.2019</td>
<td valign="top">DOE/ELT</td>
<td valign="top">Laser Projection Subunits for the Extremely Large Telescope</td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end