// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Laser Projection Subunits for the (?<Extracted_value>.*?)<\/td>").unwrap();
let string = "<td valign=\"top\">23.01.2019</td>
<td valign=\"top\">DOE/ELT</td>
<td valign=\"top\">Laser Projection Subunits for the Extremely Large Telescope</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}