#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\[(.*)("id": )(".*").*}.*(\[.*\]).*\]"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "id": "12erf3-312331-233"" & @CRLF & _
" }," & @CRLF & _
" [" & @CRLF & _
" {" & @CRLF & _
" "id": "1234"," & @CRLF & _
" "id2": "1234"," & @CRLF & _
" "id3": "1234"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "id": "1234"," & @CRLF & _
" "id2": "1234"," & @CRLF & _
" "id3": "1234"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "id": "1234"," & @CRLF & _
" "id2": "1234"," & @CRLF & _
" "id3": "1234"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "id": "1234"," & @CRLF & _
" "id2": "1234"," & @CRLF & _
" "id3": "5555"" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")