import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(.*)(\"id\": )(\".*\").*\\}.*(\\[.*\\]).*\\]";
final String string = "[\n"
+ " {\n"
+ " \"id\": \"12erf3-312331-233\"\n"
+ " },\n"
+ " [\n"
+ " {\n"
+ " \"id\": \"1234\",\n"
+ " \"id2\": \"1234\",\n"
+ " \"id3\": \"1234\"\n"
+ " },\n"
+ " {\n"
+ " \"id\": \"1234\",\n"
+ " \"id2\": \"1234\",\n"
+ " \"id3\": \"1234\"\n"
+ " },\n"
+ " {\n"
+ " \"id\": \"1234\",\n"
+ " \"id2\": \"1234\",\n"
+ " \"id3\": \"1234\"\n"
+ " },\n"
+ " {\n"
+ " \"id\": \"1234\",\n"
+ " \"id2\": \"1234\",\n"
+ " \"id3\": \"5555\"\n"
+ " }\n"
+ " ]\n"
+ "]";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}