using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(.*)(""id"": )("".*"").*}.*(\[.*\]).*\]";
string input = @"[
{
""id"": ""12erf3-312331-233""
},
[
{
""id"": ""1234"",
""id2"": ""1234"",
""id3"": ""1234""
},
{
""id"": ""1234"",
""id2"": ""1234"",
""id3"": ""1234""
},
{
""id"": ""1234"",
""id2"": ""1234"",
""id3"": ""1234""
},
{
""id"": ""1234"",
""id2"": ""1234"",
""id3"": ""5555""
}
]
]";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}