import re
regex = re.compile(r"\[(.*)(\"id\": )(\".*\").*}.*(\[.*\]).*\]", flags=re.DOTALL)
test_str = ("[\n"
" {\n"
" \"id\": \"12erf3-312331-233\"\n"
" },\n"
" [\n"
" {\n"
" \"id\": \"1234\",\n"
" \"id2\": \"1234\",\n"
" \"id3\": \"1234\"\n"
" },\n"
" {\n"
" \"id\": \"1234\",\n"
" \"id2\": \"1234\",\n"
" \"id3\": \"1234\"\n"
" },\n"
" {\n"
" \"id\": \"1234\",\n"
" \"id2\": \"1234\",\n"
" \"id3\": \"1234\"\n"
" },\n"
" {\n"
" \"id\": \"1234\",\n"
" \"id2\": \"1234\",\n"
" \"id3\": \"5555\"\n"
" }\n"
" ]\n"
"]")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")