// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)\[(.*)("id": )(".*").*}.*(\[.*\]).*\]"#).unwrap();
let string = "[
{
\"id\": \"12erf3-312331-233\"
},
[
{
\"id\": \"1234\",
\"id2\": \"1234\",
\"id3\": \"1234\"
},
{
\"id\": \"1234\",
\"id2\": \"1234\",
\"id3\": \"1234\"
},
{
\"id\": \"1234\",
\"id2\": \"1234\",
\"id3\": \"1234\"
},
{
\"id\": \"1234\",
\"id2\": \"1234\",
\"id3\": \"5555\"
}
]
]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}