re = /\[(.*)("id": )(".*").*}.*(\[.*\]).*\]/
str = '[
{
"id": "12erf3-312331-233"
},
[
{
"id": "1234",
"id2": "1234",
"id3": "1234"
},
{
"id": "1234",
"id2": "1234",
"id3": "1234"
},
{
"id": "1234",
"id2": "1234",
"id3": "1234"
},
{
"id": "1234",
"id2": "1234",
"id3": "5555"
}
]
]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end