# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http)(:[^\s]+)/$1s$2/gm;t' <<< "http://some_domain.com/some_link/"