const regex = /(http)(:[^\s]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http)(:[^\\s]+)', 'gm')
const str = `http://some_domain.com/some_link/`;
const subst = `$1s$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);