$re = '/(http)(:[^\s]+)/m';
$str = 'http://some_domain.com/some_link/';
$subst = "$1s$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;