# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B\.\b/DOT/gm;t' <<< "Conversion of code written in C# to Visual Basic .NET (VB.NET)."