$re = '/\B\.\b/m';
$str = 'Conversion of code written in C# to Visual Basic .NET (VB.NET).';
$subst = "DOT";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;