import Foundation
let pattern = #"\B\.\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"Conversion of code written in C# to Visual Basic .NET (VB.NET)."##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"DOT"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)