use strict;
my $str = 'Conversion of code written in C# to Visual Basic .NET (VB.NET).';
my $regex = qr/\B\.\b/mp;
my $subst = 'DOT';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";