re = /\B\.\b/m
str = 'Conversion of code written in C# to Visual Basic .NET (VB.NET).'
subst = 'DOT'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result