#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""[\s\w]+(\b[Cc]omponent\b)[^"\n]*"|"[^"\n]*(\b[Cc]omponent\b)[\s\w]+""
Local $sString = "Matches:" & @CRLF & _
""Component is "" & @CRLF & _
"" in component"" & @CRLF & _
"" for component "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"No Match:" & @CRLF & _
""Component"" & @CRLF & _
"Component is " & @CRLF & _
""incomponent"" & @CRLF & _
" for component " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")