re = /"[\s\w]+(\b[Cc]omponent\b)[^"\n]*"|"[^"\n]*(\b[Cc]omponent\b)[\s\w]+"/
str = 'Matches:
"Component is "
" in component"
" for component "
No Match:
"Component"
Component is
"incomponent"
for component
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end