package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[\s\w]+(\b[Cc]omponent\b)[^"\n]*"|"[^"\n]*(\b[Cc]omponent\b)[\s\w]+"`)
var str = `Matches:
"Component is "
" in component"
" for component "
No Match:
"Component"
Component is
"incomponent"
for component
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}