using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[\s\w]+(\b[Cc]omponent\b)[^""\n]*""|""[^""\n]*(\b[Cc]omponent\b)[\s\w]+""";
string input = @"Matches:
""Component is ""
"" in component""
"" for component ""
No Match:
""Component""
Component is
""incomponent""
for component
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}