$re = '/"[\s\w]+(\b[Cc]omponent\b)[^"\n]*"|"[^"\n]*(\b[Cc]omponent\b)[\s\w]+"/';
$str = 'Matches:
"Component is "
" in component"
" for component "
No Match:
"Component"
Component is
"incomponent"
for component
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);