import Foundation
let pattern = #""[\s\w]+(\b[Cc]omponent\b)[^"\n]*"|"[^"\n]*(\b[Cc]omponent\b)[\s\w]+""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Matches:
"Component is "
" in component"
" for component "
No Match:
"Component"
Component is
"incomponent"
for component
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)