# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=(var\d+))//gm;t' <<< "print var1, var2, var3
var1
var1 var23"