use strict;
my $str = 'print var1, var2, var3
var1
var1 var23';
my $regex = qr/(?=(var\d+))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";