$re = '/(?=(var\d+))/m';
$str = 'print var1, var2, var3
var1
var1 var23';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;