#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=(var\d+))"
Local $sString = "print var1, var2, var3" & @CRLF & _
"var1 " & @CRLF & _
"var1 var23"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)