re = /(?=(var\d+))/m
str = 'print var1, var2, var3
var1
var1 var23'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result