const regex = new RegExp('(?=(var\\d+))', 'gm')
const str = `print var1, var2, var3
var1
var1 var23`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);