# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\w.-]+)(\\/[\w.-]+)$/homecenter$2/gm;t' <<< "res/icons/android/quickshop/icon-36-ldpi.png
res/icons/android/quickshop/icon-48-mdpi.png
res/icons/ios/quickshop/icon-72-hdpi.png
res/icons/ios/quickshop/icon-96-xhdpi.png"