import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w.-]+)(\\/[\\w.-]+)$";
final String string = "res/icons/android/quickshop/icon-36-ldpi.png\n"
+ "res/icons/android/quickshop/icon-48-mdpi.png\n"
+ "res/icons/ios/quickshop/icon-72-hdpi.png\n"
+ "res/icons/ios/quickshop/icon-96-xhdpi.png";
final String subst = "homecenter$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}