import re
regex = re.compile(r"([\w.-]+)(\/[\w.-]+)$", flags=re.MULTILINE)
test_str = ("res/icons/android/quickshop/icon-36-ldpi.png\n"
"res/icons/android/quickshop/icon-48-mdpi.png\n"
"res/icons/ios/quickshop/icon-72-hdpi.png\n"
"res/icons/ios/quickshop/icon-96-xhdpi.png")
subst = "homecenter$2"
result = regex.sub(subst, test_str)
if result:
print(result)