package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\w.-]+)(\/[\w.-]+)$`)
var str = `res/icons/android/quickshop/icon-36-ldpi.png
res/icons/android/quickshop/icon-48-mdpi.png
res/icons/ios/quickshop/icon-72-hdpi.png
res/icons/ios/quickshop/icon-96-xhdpi.png`
var substitution = "homecenter$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}