#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([\S\s]*?^[^][]*=)\[\[[^][]*\[[^][]*\]\]\K\]\R[^][]*\[(.*)\]$(?!\R\1)"
Local $sString = "1 NameA - DirectionA=[[StreetA @ StreetB,[Lat,Long]]]" & @CRLF & _
"1 NameA - DirectionA=[[StreetC @ StreetD,[Lat,Long]], [StreetF @ StreetE,[Lat,Long]]]" & @CRLF & _
"1 NameA - DirectionB=[[StreetE @ StreetF,[Lat,Long]], [StreetG @ StreetH,[Lat,Long]]]" & @CRLF & _
"2 NameB - DirectionC=[[StreetI @ StreetJ,[Lat,Long]], [StreetK @ StreetL,[Lat,Long]]]" & @CRLF & _
"2 NameB - DirectionD=[[StreetM @ StreetN,[Lat,Long]], [StreetO @ StreetP,[Lat,Long]]]"
Local $sSubst = ", \2]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)