$re = '/^([\S\s]*?^[^][]*=)\[\[[^][]*\[[^][]*\]\]\K\]\R[^][]*\[(.*)\]$(?!\R\1)/m';
$str = '1 NameA - DirectionA=[[StreetA @ StreetB,[Lat,Long]]]
1 NameA - DirectionA=[[StreetC @ StreetD,[Lat,Long]], [StreetF @ StreetE,[Lat,Long]]]
1 NameA - DirectionB=[[StreetE @ StreetF,[Lat,Long]], [StreetG @ StreetH,[Lat,Long]]]
2 NameB - DirectionC=[[StreetI @ StreetJ,[Lat,Long]], [StreetK @ StreetL,[Lat,Long]]]
2 NameB - DirectionD=[[StreetM @ StreetN,[Lat,Long]], [StreetO @ StreetP,[Lat,Long]]]';
$subst = ", \2]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;