using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\S\s]*?^[^][]*=)\[\[[^][]*\[[^][]*\]\]\K\]\R[^][]*\[(.*)\]$(?!\R\1)";
string substitution = @", \2]";
string input = @"1 NameA - DirectionA=[[StreetA @ StreetB,[Lat,Long]]]
1 NameA - DirectionA=[[StreetC @ StreetD,[Lat,Long]], [StreetF @ StreetE,[Lat,Long]]]
1 NameA - DirectionB=[[StreetE @ StreetF,[Lat,Long]], [StreetG @ StreetH,[Lat,Long]]]
2 NameB - DirectionC=[[StreetI @ StreetJ,[Lat,Long]], [StreetK @ StreetL,[Lat,Long]]]
2 NameB - DirectionD=[[StreetM @ StreetN,[Lat,Long]], [StreetO @ StreetP,[Lat,Long]]]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}