# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([\S\s]*?^[^][]*=)\[\[[^][]*\[[^][]*\]\]\K\]\R[^][]*\[(.*)\]$(?!\R\1)"
test_str = ("1 NameA - DirectionA=[[StreetA @ StreetB,[Lat,Long]]]\n"
"1 NameA - DirectionA=[[StreetC @ StreetD,[Lat,Long]], [StreetF @ StreetE,[Lat,Long]]]\n"
"1 NameA - DirectionB=[[StreetE @ StreetF,[Lat,Long]], [StreetG @ StreetH,[Lat,Long]]]\n"
"2 NameB - DirectionC=[[StreetI @ StreetJ,[Lat,Long]], [StreetK @ StreetL,[Lat,Long]]]\n"
"2 NameB - DirectionD=[[StreetM @ StreetN,[Lat,Long]], [StreetO @ StreetP,[Lat,Long]]]")
subst = ", \\2]"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.