const regex = /^([\S\s]*?^[^][]*=)\[\[[^][]*\[[^][]*\]\]\K\]\R[^][]*\[(.*)\]$(?!\R\1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\S\\s]*?^[^][]*=)\\[\\[[^][]*\\[[^][]*\\]\\]\\K\\]\\R[^][]*\\[(.*)\\]$(?!\\R\\1)', 'gm')
const str = `1 NameA - DirectionA=[[StreetA @ StreetB,[Lat,Long]]]
1 NameA - DirectionA=[[StreetC @ StreetD,[Lat,Long]], [StreetF @ StreetE,[Lat,Long]]]
1 NameA - DirectionB=[[StreetE @ StreetF,[Lat,Long]], [StreetG @ StreetH,[Lat,Long]]]
2 NameB - DirectionC=[[StreetI @ StreetJ,[Lat,Long]], [StreetK @ StreetL,[Lat,Long]]]
2 NameB - DirectionD=[[StreetM @ StreetN,[Lat,Long]], [StreetO @ StreetP,[Lat,Long]]]`;
const subst = `, \2]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);