#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(main).*@(?:gmail|hotmail).com)"
Local $sString = "123main456@gmail.com = match" & @CRLF & _
"" & @CRLF & _
"123main@hotmail.com = match" & @CRLF & _
"" & @CRLF & _
"someonemain@gmail.com = no match" & @CRLF & _
"" & @CRLF & _
"123main456@agmail.com = match" & @CRLF & _
"" & @CRLF & _
"123main@hotamail.com = match" & @CRLF & _
"" & @CRLF & _
"someone@gmail.com = no match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")