const regex = /(?=(main).*@(?:gmail|hotmail).com)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(main).*@(?:gmail|hotmail).com)', 'gm')
const str = `123main456@gmail.com = match
123main@hotmail.com = match
someonemain@gmail.com = no match
123main456@agmail.com = match
123main@hotamail.com = match
someone@gmail.com = no match`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}