use strict;
my $str = '123main456@gmail.com = match
123main@hotmail.com = match
someonemain@gmail.com = no match
123main456@agmail.com = match
123main@hotamail.com = match
someone@gmail.com = no match';
my $regex = qr/(?=(main).*@(?:gmail|hotmail).com)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}