re = /(?=(main).*@(?:gmail|hotmail).com)/m
str = '123main456@gmail.com = match
123main@hotmail.com = match
someonemain@gmail.com = no match
123main456@agmail.com = match
123main@hotamail.com = match
someone@gmail.com = no match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end