using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(main).*@(?:gmail|hotmail).com)";
string input = @"123main456@gmail.com = match
123main@hotmail.com = match
someonemain@gmail.com = no match
123main456@agmail.com = match
123main@hotamail.com = match
someone@gmail.com = no match";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}