const regex = /([^\\]+)\\(\S+)\s([^\\]+)\\([^\\]+)\\(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\\\]+)\\\\(\\S+)\\s([^\\\\]+)\\\\([^\\\\]+)\\\\(.+)', 'gm')
const str = `Projects\\UP/PS (21063)\\2789 (spain) / Ref/15\\Email
casi, serĂan 1=Projects (pero es tan facil que lo he obviado), 2=UP/PS, 3=(21063), 4=2789 (spain) / Ref/15, 5=Email`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}