re = /([^\\]+)\\(\S+)\s([^\\]+)\\([^\\]+)\\(.+)/m
str = 'Projects\\UP/PS (21063)\\2789 (spain) / Ref/15\\Email
casi, serían 1=Projects (pero es tan facil que lo he obviado), 2=UP/PS, 3=(21063), 4=2789 (spain) / Ref/15, 5=Email'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end