use strict;
my $str = 'Projects\\UP/PS (21063)\\2789 (spain) / Ref/15\\Email
casi, serían 1=Projects (pero es tan facil que lo he obviado), 2=UP/PS, 3=(21063), 4=2789 (spain) / Ref/15, 5=Email';
my $regex = qr/([^\\]+)\\(\S+)\s([^\\]+)\\([^\\]+)\\(.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}