import re
regex = re.compile(r"([^\\]+)\\(\S+)\s([^\\]+)\\([^\\]+)\\(.+)", flags=re.MULTILINE)
test_str = ("Projects\\UP/PS (21063)\\2789 (spain) / Ref/15\\Email\n\n\n\n"
"casi, serĂan 1=Projects (pero es tan facil que lo he obviado), 2=UP/PS, 3=(21063), 4=2789 (spain) / Ref/15, 5=Email")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")